19 month MRI Scan

Posted on August 30, 2010 by quashnsa

I had my 19 month MRI scan last Friday (Aug, 27 2010). I have looked at the images and found no new growth at the tumor site. Good news for me!

MRI Images

Some Useful Scripts

Posted on August 13, 2010 by Stephen

I am always searching for some simple scripts to make my life easier. Here are a few that I have used.

This script removes the spaces from file names and directories. It replaces them with the underscore "_". It must be run several times due to the changes in `find` when a directory name has changed.


#!/bin/sh
find . -name '* *' | while read file;
do
target=`echo "$file" | sed 's/ /_/g'`;
echo "Renaming '$file' to '$target'";
mv "$file" "$target";
done;


This script I have used to concatenate large numbers of ascii text files. It adds a column for the file name so the final output file has a reference back to the original file.


#!/bin/sh
for i in `ls *.[Rr][Ss][Ff]`
do
awk '{print "\"" FILENAME "\"\t" "\"xxx\"" "\t" $0}' $i >> outfile.txt
done

Boating Lake Tahoe and Emerald Bay

Posted on August 07, 2010 by quashnsa

I finally took my dad for a ride to Emerald Bay. When I was younger, I promised to give him a ride to Emerald Bay when I bought a boat. I traveled by myself with the boat for the first time. I was nervous about launching since my boat buddy was not with me--she had to work. There was a mandatory boat inspection that I drove back to Meyers. The cost is based on boat length and horsepower. For a three day pass, it cost me $55 for my 320hp boat. While I was driving back to Meyers for my boat inspection, I had to stop at the inspection station leaving South Lake Tahoe. I was informed there that a fine of $350 could be issued if a boater was caught traveling with the drain plug still fastened to the boat. I have never traveled with the drain plug in, so I was free to go.

Fixing FreeBSD 8.0 HD

Posted on August 03, 2010 by Stephen

I had a mental lapse the other day and hit the reboot button while the system was loading. What an idiot! After rebooting the system, it would shutdown after 15-20 minutes of uptime. There were cases of excessive sync numbers and the partitions were flagged as "not properly unmounted". After some searches on the 'net, I remembered that for fsck to repair the damage, I would have to run it on unmounted partitions. This solved the problem.